PDA

View Full Version : 80 gurus


nuclearlemon
04-03-2010, 09:10 PM
few ??? in the what is the gasket in the fsm that i circled and where does it go...it looks like it goes up, but i don't see where, then what are the items circled in the pic of the front cover and should i replace seals there while i'm doing front main and (hopefully) oil pump cover? tia

ttubb
04-03-2010, 10:30 PM
Ige, the gasket looks like the oil pick-up tube gasket. Is there another view with the oil pick-up tube that may show this? Terry

sleeoffroad
04-04-2010, 08:41 AM
The one on the left is the crank position sensor. It has a o-ring that can not be bought on it's own and it is not a regular o-ring.

TIMZTOY
04-04-2010, 11:01 AM
The one on the left is the crank position sensor. It has a o-ring that can not be bought on it's own and it is not a regular o-ring.

is it a square cut o-ring ?

Corbet
04-04-2010, 11:16 AM
I don't know Ige but get this all figured out for me as I ordered my parts from CDan and will be doing the same in a few days.

corsair23
04-04-2010, 11:59 PM
Ige,

You already know you are WAY beyond my level of help :hill: - but good luck!

Just found out yesterday the :Princess:'s 80 wouldn't start...WTF...tap the starter and it starts right up :mad: - I guess I'm 0 for 2 on starter rebuilds on her 80. Time to have someone do it right I guess. The LX has been fine for ~3 years after I rebuilt it so go figure. Just proof you are beyond my help :hill:

Inukshuk
04-12-2011, 09:54 PM
What is the thing on the right. Mine is leaking oil.
Its not the Crank Position Sensor because mine is a 93 and does not have one. :thumb:

nuclearlemon
04-13-2011, 11:17 AM
can't remember what christo told me, outside of 'that's not your leak'. check your ps pump, that's what mine ended up being. when you bring back the tre puller, we can put some oil dye in and trace your leak also.

Red_Chili
04-13-2011, 11:32 AM
Just found out yesterday the :Princess:'s 80 wouldn't start...WTF...tap the starter and it starts right up :mad: - I guess I'm 0 for 2 on starter rebuilds on her 80. Time to have someone do it right I guess.
You can still do it right. Replace the plunger as well as the contacts and you are golden for another 100K.

Unless cruisers are unlike minitrucks in this area... sorry, UB! LOL

nuclearlemon
04-13-2011, 12:15 PM
You can still do it right. Replace the plunger as well as the contacts and you are golden for another 100K.

Unless cruisers are unlike minitrucks in this area... sorry, UB! LOL

i'm betting he fixed it a year ago, since his post is that old;)

Inukshuk
04-13-2011, 01:07 PM
can't remember what christo told me, outside of 'that's not your leak'. check your ps pump, that's what mine ended up being. when you bring back the tre puller, we can put some oil dye in and trace your leak also.

Good point. My PS pump s leaking. I am leaning towards ordering the rebuild kit and hose gaskets today (Great Romer FAQ on Mud)

I was looking but have not yet found if someone had a part number for a good option for a non-Toyota high pressure power steering hose - OEM is about $200. Does anyone know that?

Jacket
04-13-2011, 01:56 PM
I just noticed my PS box is leaking, so I'll be diving into this one too. The part number per Mud for the Gates hose:

77416555 365550

Jacket
04-13-2011, 01:59 PM
http://www.autopartswarehouse.com/details/QQLexusQQLX450QQGatesQQPower_Steering_HoseQQ19961997QQGAT365550.html

Inukshuk
04-13-2011, 02:43 PM
I just noticed my PS box is leaking too, so I'll be diving into this one too. The part number per Mud for the Gates hose:

77416555 365550

Thanks! Ordered. While that one is for a 95-96 LX450, the 93 LandCruiser (mine) PN is identical.

coax
04-13-2011, 03:18 PM
Just for future reference I think the one I picked up from napa a few weeks back is in the 55 dollar range. I have yet to install but it looks ok and reports on mud seem about as good as they get for a non-oem part. :D