PDA

View Full Version : Wiring question


Boulder Cruiser
05-01-2010, 04:43 PM
I just got a 97 LC that has the engine wiring harness melted and a few wires in the dash harness. I got both harness's to replace them but later found out that they are from a 95. My mechanic said that so far everything is going well besides the plug that goes to the Antenna ECU and one of the plugs for the climate control.

So i know that in 96 they changed the ecu for the antenna to go up and down when you turn the truck off. Im thinking that's why its not matching???? I was thinking i can just get the ecu off a 95 and call it good.

Next question is since they changed the the tranny in 96 and the harness is from a 95 is the plug that goes down to it going to match?

Any other things you guys can think of that could go wrong? I figured i would just have him start the install and see if anything pops up but if they don't match then I'd rather know now and find another harness.

LARGEONE
05-02-2010, 08:31 AM
The tranny for the '95 should be the same tranny as 96/97, unless it was a super-early '95.

TIMZTOY
05-02-2010, 10:49 PM
That depends on generation. If you've got the 3.4 all the year computers should be the same in that generation as long as it's a 3.4. If you have the 4cyl then get the 4cly comp from same generation. And I didn't relize there was a antena computer. Do u mean the body controle module ? The antena motor is just a 12 power amd ground. You could just run your own 12v power suply from the radio on/off wire !

Boulder Cruiser
05-11-2010, 10:54 AM
Ok everything is coming together. We figured out were it started it was the white/red trace wire from the positive cable on the battery, Can someone look on there truck and tell me what size the fuse link is?
It looks like it was replaced by the PO with just a normal wire.