View Full Version : Is this a Horn Relay?!

12-12-2011, 07:35 AM
Hey Guys, First post ! Love the webpage, been reading for quite a while, thought id actually bite the bullet and sign up !

Ive been having some troubles with the horn on my 40, got this new relay but im unsure if its actually.. correct or not?

Have a look, see what you think. Ive never see one like it before, with screw terminals and all.. hahah:confused:

Any of you guys have a 40 with a relay like this?!


12-12-2011, 09:19 AM
Sorry, no help on the relay. But , WELCOME!!

12-12-2011, 09:37 AM
Yes if your Cruiser is a 1958 to October 1969 and should go on the firewall in spot 14. The early ones were clear, later ones were metal but I'll let Wes confirm that one. My memory is fading...

1958-10/69 - mounted to the firewall (14in 2nd pic)

10/69-7/80 - mounted to the fender just in front of the heater blower (last pic)




12-12-2011, 05:02 PM
Looks like Mike has you covered but this thread might prove helpful also (for later model year 40s)


12-12-2011, 06:03 PM

Not even 12 hours later and an outstanding reply without any bull-****. You guys are fantastic.

Thankyou.. !!

12-12-2011, 08:57 PM
I think mine has a metal cover but I'll have to look again.

that one it pretty clean :) where did you find it?

12-13-2011, 03:02 AM
haha cheers : )

I got a few relays and things a while back, ive got a bag full of these darn things. Kinda cool how they are see through and all !

Air Randy
12-13-2011, 08:09 PM
The horn on my shorty stopped working shortly after I got it. I considered replacing the relay, the horn itself, etc. Turned out it was a bad ground. Check to make sure all of your grounds are clean (bettery cable, etc) before you start replacing parts.