View Full Version : 1987 4 runner fuel problem

03-13-2008, 02:06 PM
My 4 runner will not start and narrowed it do to the fuel. I and not getting any fuel at all. Enen before the filter. I checked and tested relays and everything check out. I have a Haynes manuel and it tells me to check ifb I am getting voltage on the Fp terminal. I am only getting 9 volts cranking. I checked to see if I was getting voltage back by the fuel tank with ignition on or cranking and not getting anything. I was wondering it the ECU would cause the voltage issue?

I don't want by epensive parts without know it that was really the problem.

Any help would be greatly appreciated.

03-13-2008, 03:14 PM
Keep in mind that my truck is a 1991, so I will assume that your 22R-E is similar enough to mine.

Is the engine cranking (not just the starter turning, but the engine is actually turning over). If so, sounds like you are not getting the fuel pump to turn on (good deduction, eh?). You expect anything from 9V to 14V at various places on the ECU when you diagnose it, although measuring 9V cranking wouldn't surprise me.

So /no/ pressure in the fuel lines into the engine bay, right? Just making sure that the fuel pump is really definitely not running when you're trying to start.

-Any trouble codes stored in the ECU?
-Any other things electrical not working? In particular, does the ignition happen to be dead (check that you are getting spark while cranking).

-Check the EFI fuse in the main fuse block
-Check the AM2 fuse in the main fuse block (this feeds the EFI fuse as well as the ignition fuse, which is why I asked)

-Check the EFI relay (main fuse block in engine bay). The EFI Relay is relatively easy to check. Put voltage across terminals 1 and 3 and if the resistance between 2 and 4 is zero then the terminals are closed. With no voltage across 1 and 3, the resistance between 2 and 4 should be infinity (the contacts should have opened).

-Check the Circuit Opening relay (mine is up under the dash by the ECU). The Circuit Opening Relay is slightly more complex. Battery voltage across STA and E1. Terminals +B and Fp should close and +B and Fc should close. No voltage at STA and E1, both contacts should be open.

-Check the Starter relay (main fuse block in engine bay). Battery voltage across terminals 1 and 2, should see 3 and 5 get continuity. With no voltage at 1 and 2, terminals 3 and 5 should also be open.

If all of these check OK, check the wiring to the fuel pump. If you seem to have battery voltage there, the fuel pump might have failed. That's not so easy to diagnose in place, you have to take it out.

It's also possible that a fuel line is just clogged.

03-13-2008, 05:34 PM
Hi Dave,

Thanks for getting back with great information. Yes the engine turns over but would not start. I did all the test for the relay per instruction from the Haynes book. The relays that I have located is below the fuse panel on driver side, the other is located behind the glove box next to the heater and AC fuses and the open circuit relay on the passenger side by the ECU unit. I cannot find the EFI main fuse in the engine bay. I believe this is the same one one the driver side by the fuse panel. I also checked the EFI fuse on the fuse panel and all checks out good.

That is correct no pressure in the line to engine bay. I even loosened the line between the pump and filter and definely no fuel pumping. I did check for voltage at the line to the fuel pump and I get none thats with key on or cranking.

I don't have a scanner to plug in for codes.

When I tested these relays I did a resistance test per the manual and test all came out good. I did not add voltage. Is testing it with voltage applied going to read different?

Raining out now but when I get a chance I'm going to try and trace the wire from the pump to the the relay as I get no voltage at the plug for the pump.

03-13-2008, 05:43 PM
This happened to me, it was the fuel pump/sending unit. Costly, but fixed it right up.

Not sure if that's your issue, but you could test it.

03-13-2008, 06:22 PM
I don't have a scanner to plug in for codes.
You can read the codes yourself. There are two terminals in the diagnostic plug in the engine bay you jump. That plug hangs off the side of the main fuse block and says diagnostic (I think). Jump E1 and T together and that puts the ECU into diagnostic mode. It will flash the Check Engine light on the dash when you turn the key to ignition (NOT START!) and you can read the codes that way. If you search the Internet you should be able to find more about it.

03-13-2008, 08:02 PM
It shouldn't be your fuel pump that has gone bad if you have no voltage at the fuel pump with the engine cranking. You will never get voltage at the pump if the key is on, but the engine isn't running. The computer is smarter than that and wouldn't let the pump run continuously if the motor isn't running. If I remember correctly and if its like most cars you should also get voltage at the pump when you first turn the key to the on position from off for about 5 sec or so. This is so the pump can build up and pressure that has bled down before trying to start. So you could also check that if you have somebody to help you.

If you still have no power at all at the pump I would check voltage on the output leg of the fuel pump relay. That would determine if you have a wiring problem between the relay and the pump. If no voltage there check to see if you have voltage coming into the the relay on the input and output side. If you have voltage on the pump side of the relay that is good. If you don't you have a problem between the batter and the relay, and your vehicle is a different wiring than mine so I will be no help there. If you dont have a signal to the relay from the ECM on the input side of the relay you could have a problem with a number of things like...ECM, CPS, Cam position sensor, bad wiring between ECM and relay. All sorts of things.

Hope this helps some, I have had these problems before on a number of vehicles. One other thing you might try is to manually put power to the pump and try and start the engine. If It doesn't start there is something else going on like with the ECM or sensors on the engine.

03-13-2008, 08:34 PM
ECM, CPS, Cam position sensor, bad wiring between ECM and relay.
Possible, if the 22R-E had any of those. No crank sensor, no cam sensor on the engine. If there is no voltage at the fuel pump then it has to be the AM2 or EFI fuse, EFI relay, circuit opening relay, AFM fuel pump switch or the starter relay. There's nothing else in the circuit. The ECU only talks to the fuel pressure VSV, not to the pump directly. The fuel pump cut out is based on the circuit opening relay and the AFM switch. If the air flowing through the AFM stops, the switch inside opens, which cuts the fuel pump by way of the relay. The only time the fuel pump is not controlled by the AFM is during cranking, when the circuit opening relay is being energized by the starter relay. The circuit opening relay has two coils, one is normally energized by the AFM and the other by the starter relay.

I forgot, there is a very important additional step!

If you short +B to the Fp in the diagnostic connection, it will bypass the circuit opening relay and the AFM switch. It will make the fuel pump run with the key to ignition as along as the EFI fuse and the EFI main relay are still working. This is where the early and late 22R-E systems might differ. On early 22R-E engines the bypass leaves the circuit opening relay in the diagnostic circuit (just bypassing the AFM switch) and in mine it seems that the Fp-to-+B jumper also bypasses the circuit opening relay. At least according to the FSM diagram. I dunno in a 1987 if the circuit opening is bypassed or not. It might not be bypassed with the diagnostic jumper between Fp and +B.

If jumping the Fp to +B does not make the fuel pump run, then the AM2 fuse, EFI fuse, EFI relay, pump or wiring have to be bad.

If it does run, then it has to be the control circuit, which is the starter relay, circuit opening relay, AFM. Also check that the ALT and AM1 fuses are good. I'd then check that the switch in the AFM is good and if so, then look at replacing the circuit opening relay.

03-14-2008, 01:40 AM
Thanks for everyones great information. I have tested the EFI fuse, EFI relay and the open circuit relay and all came out good. The only one I have not been able to locate is the AM2 fuse. Is there another name for it? I did test all fuses in the fuse panel and all is good. I did try the +B to FP jump and turned on ignition and pump doesnot come on.

Dave suggested It has to be the AM2 fuse which is the only fuse I have not tested I need another name or help locating this fuse. it or the wiring between the pump and the relay.

03-14-2008, 06:43 AM
Keep in mind, this is all in my '91.

The AM1 and AM2 are the big 30A (AM2) and 40A (AM1) fuses in the main box, right side behind the battery. In my fuse panel they are between to the huge 80A ALT fuse and the headlight relay.

If either of those was blown, you'd have several electrical things not working.

03-14-2008, 08:41 AM
I'll check that out this evening when I get home from work. I Haven't noticed any other components not working. If AM2 checks out fine, I'll start with wires between pump and relay.


03-14-2008, 08:49 AM
www.4Crawler.com has a page on fuel relay problems. See if Roger can't fix you up.

03-15-2008, 09:49 PM
I found the AM1 and AM 2 fuses. I tested and all is good. I traced the wire from the fuel pump up to the inside underneath the passenger seat. I disconnected the plug under the seat and crank the engine and still no power at either the white or the blue wire.

What is the chances of a bad relay regardless if all test came out good?

Hopefully I can get a chance to get out and try and trace more wire.

03-20-2008, 10:28 PM
I have replaced all relays to include the circuit open relay and still nothing. I also replace the pump and still not getting anything. Out of options?? I can spray starting fluid into the throttle body and get it to fire up for a few secs then cuts out after the starting fluid is gone. I have ran a direct power from anothr sorce to the old fuel pump prior to changing and I can get it to fire up but would not stay running. Acts as it was not getting enough fuel pressue. Would the cold start valve have anything to do with this?