PDA

View Full Version : AT Temp Light


timmbuck2
03-31-2009, 10:00 AM
AT Temp idiot light came on in my friend's 62 this morning. I checked the tranny fluid and it looked ok (but it was cold, did not check when hot). Don't have a manual and I have no 60 experience at all. What should I look at? thanks.

T

timmbuck2
03-31-2009, 10:14 AM
AT Temp idiot light came on in my friend's 62 this morning. I checked the tranny fluid and it looked ok (but it was cold, did not check when hot). Don't have a manual and I have no 60 experience at all. What should I look at? thanks.

T

More info...the light just came on while driving on 285 in town for 15-20 minutes...no extended driving or anything...

timmbuck2
03-31-2009, 09:19 PM
definitely sounds like a sensor or something else now....the truck was parked for 3 hours this afternoon in the cold and wind....when she started it up again the light came on right away...

Chris
03-31-2009, 09:34 PM
IIRC mine flashed on for a moment before seizing...

isotel
04-01-2009, 02:49 PM
IIRC mine flashed on for a moment before seizing...

:doh:

calphi27
04-01-2009, 06:33 PM
pending weather, i should be putting a aux cooler on my 62 for the brifield packing party this sat. if your friend is around, he should check it out.

Chris
04-01-2009, 07:50 PM
Hugh at Safari LTD who tore down my A440F after failure believes the tranny cooler (bottom of radiator) was plugged causing overheating. Overheating kills these, don't take it lightly or make any assumptions.