Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   General Tech Forum (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=17)
-   -   3FE Pro? (http://www.risingsun4x4club.org/forum2/showthread.php?t=13821)

Chris 08-20-2010 04:09 PM

3FE Pro?
 
After failing emissions 3 times due to high NOx I'm in need of expert help in diagnosing why. The limit is 5.0 and I've gotten 7.5 the first time, 8.1 after tuning it up & today 11.2 which shows I'm moving in the wrong direction. :eek:

I did find a crack in the intake 'accordian' and thought I sealed it well but apparently not which would account for some of the increase but even when I replace that I'll probably still be high since I started out high. I'm guessing I split that when I tuned it and put it back on. :o

Anyone dealt with this or knows the emissions well that can find what's going on?

TIA!

Chris

wesintl 08-20-2010 04:19 PM

most likely cats, How old are they chris?
http://www.risingsun4x4club.org/foru...1&postcount=13

Chris 08-20-2010 04:31 PM

1 year old Wes, I went back to Scott at AAPerformance Muffler and they checked out fine. Working hard but as good as the day installed. Scott said my EGR tube was probably gunked up so I pulled that and it's clean. I had a flat spot on acceleration which was fixed by the tune-up and the trucks running better but the NOx is increasing. :(

wesintl 08-20-2010 04:39 PM

I thought I remember you saying they were new.. EGR valve? is it running lean?

Chris 08-20-2010 04:55 PM

The EGR valve appears to be working from what I can determine. Running lean? Perhaps but isn't that controlled by the EFI?

wesintl 08-20-2010 05:11 PM

if you were to far advanced. what's the timing set at?

Chris 08-20-2010 05:23 PM

I think it's right on 7 BTDC per the FSM. I have a hard time getting a line of sight on it but it should be right. Idle at 650rpm. It does idle rough but seems the nature of these motors.

powderpig 08-20-2010 08:49 PM

Is it only NOX you are failing, can you post you other numbers as well?


How are the O 2 sensors?
If these are not working or are 80k miles down the pike, they may need to be replaced. I would only go with Denso, NTK or OEM boxed.

frontrange 08-20-2010 09:20 PM

If you are sure the EGR is working, I'd check for clogged injectors. I have a spare set I've cleaned & flow tested that I can loan out if that helps.

Chris 08-20-2010 09:27 PM

I don't know anything about both the O2 sensors or injectors. I appreciate input on how these affect NOx in particular. It's my understanding that what I'm looking for are vacuum leaks and/or EGR issues.

Latest numbers:
HC - .4027
CO - 3.77
CO2 - 668.44
NOx - 11.26

Thanks for your help.


All times are GMT -6. The time now is 09:33 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.