Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   General Tech Forum (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=17)
-   -   My oil pressure is pinned in the "H" position (http://www.risingsun4x4club.org/forum2/showthread.php?t=13832)

Rezarf 08-21-2010 06:54 PM

My oil pressure is pinned in the "H" position
 
I noticed this morning that my oil pressure guage was spiked at the "H" position. Truck seems to be running fine.

I was wondering how do I check if it is the sensor and or, what could cause this.

I noticed after the 40's only run it spiked for a few minutes then went back to normal. FWIW, my fuel gauge was maxed out WAY over the "F" but I did just fill up. One more note, I did disconnect/reconnect the guages recently to restore my gauge cluster.

thanks in advance-

Drew

Rzeppa 08-21-2010 11:19 PM

That is indicative of a short between the sender side of the gauge and ground. Do the easy stuff first. I assume it returns to the low side when the key is switched off, and pegs when the key is on, right? Probably even before the engine is running right?

Try unhooking the connector to the sender. If it is still pegged, then it is in the wiring. If it stops pegging and returns to zero, then it is a shorted sender.

Rezarf 08-22-2010 08:08 AM

Quote:

Originally Posted by Rzeppa (Post 159778)
That is indicative of a short between the sender side of the gauge and ground. Do the easy stuff first. I assume it returns to the low side when the key is switched off, and pegs when the key is on, right? Probably even before the engine is running right?

Yep, your assumptions are dead on, thanks for the steps Jeff. Time to track it down. :thumb:


All times are GMT -6. The time now is 06:16 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.