Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   General Tech Forum (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=17)
-   -   Look what Mike broke (http://www.risingsun4x4club.org/forum2/showthread.php?t=18565)

waggoner5 10-01-2012 12:10 PM

Look what Mike broke
 
1 Attachment(s)
Looks like its broken pretty bad. New engine, wiring, fuel system etc.

RicardoJM 10-01-2012 12:28 PM

Did the engine finally give up? How many miles did it have?

rover67 10-01-2012 01:08 PM

4.7 would be a sweet motor.

subzali 10-01-2012 01:11 PM

You'll have it fixed in what, say about 6 hours? ;)

Uncle Ben 10-01-2012 01:26 PM

Let me guess....it started in reverse rotation again and the only way to shut it off was to yank it out?

wesintl 10-01-2012 01:43 PM

He's installing a 7 slot bezel :eek:

Uncle Ben 10-01-2012 02:05 PM

Quote:

Originally Posted by wesintl (Post 219467)
He's installing a 7 slot bezel :eek:

:lmao::lmao: The old charging system couldn't handle to consistent voltage requirements of the 127million LEDS that he bought for the :zilla:

Hulk 10-02-2012 02:28 AM

Looking forward to seeing this with a new power plant.

treerootCO 10-28-2012 08:06 AM

3 Attachment(s)
The new engine is the one I bought from Mike Moore a few years ago mated to the SM465 and Orion I already had. It has been a fun project and really exciting to see it come together. Still need a VSS, throttle cable, exhaust, and fuel lines. Other than that, the engine is in!

Attachment 31038

Attachment 31039

Attachment 31040

MDH33 10-28-2012 08:10 AM

Beautiful. :cool:


All times are GMT -6. The time now is 11:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.