Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   General Tech Forum (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=17)
-   -   "System too lean on bank 1" on 99 4Runner (http://www.risingsun4x4club.org/forum2/showthread.php?t=19650)

Keith 05-26-2013 03:17 PM

"System too lean on bank 1" on 99 4Runner
 
Hey folks. Thought I'd run this by the experts here....

The Check Engine light on my girlfriends '99 4Runner came on 2 days ago. It has not had any driveability problems and seems to still be running just fine. We took it to NAPA and had them read the code and got "System too lean on bank 1".

So, per the recommendations of the folks at NAPA, we put in a can of fuel injector cleaner, and will fill it up with premium next time we fill it up. A web search seems to indicate we might also want to clean or replace the Mass Air Flow (MAF) sensor. So, I'll take a look at that in the next couple days.

Anyone here have any other thoughts on what we should do, or just do those and don't worry about it as long as the light doesn't come back on?

Thanks,
Keith

Squishy! 05-26-2013 06:22 PM

Clean the MAF. Guaranteed. O'Reilys sells good MAF cleaner.

rover67 05-26-2013 06:25 PM

buy the stuff that's labeled MAF cleaner, I think CRC is the brand. Carb cleaner isn't good for them.

jps8460 05-26-2013 10:17 PM

check for vacuum leaks. 2nd what Marco said about MAF cleaner.

Firetacoma 05-27-2013 08:20 AM

As others have said, the chances are excellent it's a dirty MAF sensor. Once it's cleaned, disconnect the battery to make the light go off, if it stays off you're fine.

Also, if it has a k&n oil filter or so etching similar, get rid of it. Those things dump all kinds of oil onto the sensor.

Corbet 05-27-2013 09:26 AM

What they said, and if you do put a can of fuel injector cleaner in use "BG44K". NAPA here sells it.

Squishy! 05-27-2013 10:02 AM

Quote:

Originally Posted by corbet (Post 233449)
use "bg44k

X2

Keith 05-27-2013 02:38 PM

Quote:

Originally Posted by Corbet (Post 233449)
What they said, and if you do put a can of fuel injector cleaner in use "BG44K". NAPA here sells it.

Yup, that's what we used. From our local NAPA.

Thanks again folks! Working all day today and tomorrow. Should be able to clean the MAF sensor tomorrow or the next day.

Squishy! 05-27-2013 05:34 PM

Hey if you want to swing by my place I've got a can of MAF cleaner make it a quick fix.

Keith 05-30-2013 03:00 PM

Finally got to NAPA and bought some MAF sensor cleaner. Man was it ever a pain in the ass to get to the sensor on the 4Runner. Had to take the whole airbox off... And once I got there found that 1 of the 2 screws holding the sensor in place was missing. :banghead:

Also went ahead and cleaned the MAF sensor on my Taco while I was at it. That was quite a bit easer to get to.

As an update, the light never went back on after we just put in some fuel injector cleaner, but since then I've cleaned the sensor and put in a tank of premium gas. Let's hope this will ward off any evil spirits.


All times are GMT -6. The time now is 08:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.