Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   General Tech Forum (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=17)
-   -   New Gas Tank! (http://www.risingsun4x4club.org/forum2/showthread.php?t=724)

Maddmatt 01-29-2006 08:59 AM

New Gas Tank!
 
Just felt like sharing. I purchased a new-to-me steel gas tank from Anthony in Montrose (via MUD). We did a parking lot cash for tank exchange last week as he was driving through Denver. He's a good guy, tank was as good or better than advertised. Had a tiny bit of surface rust that I hand sanded down to bare metal and rust oleumed.

Truck started right up, no leaks and no fumes :D :D :D

Seems to be a tiny bit of "weepage" around the drain bolt. I wouldn't even call it a leak, just looks kind of damp around the bolt. I put a new copper crush washer on, do I just need to be stronger? Kind of paranoid about stripping that bolt and creating a bigger problem.

So today will be the real test, I'll fill it and drive around for an hour or so after I finish tightening all the bolts. If all goes according to plan, I'll be commutting in the 40 for awhile, it's been sitting far too long.

Anybody wants a good deal on a lightly used poly tank, let me know. Has a good sending unit, keeps most of the gas inside the tank most of the time.

That is all.

Rzeppa 01-29-2006 10:51 AM

Congrats on the new tank, been a couple months since installed the new one in my 71. I had to change out the fuel filter after the first tank of fuel, but since then it's been fine.

On your weepage at the drain plug, since it's a new washer, try simply slightly loosening it then retightening it. That might help to soft copper conform to the irregulaties in the mating surfaces better, as well as crush any particulates that might be preventing a good seal.

Rzeppa 01-29-2006 10:53 AM

Quote:

Originally Posted by Maddmatt
Truck started right up, no leaks and no fumes :D :D :D

...keeps most of the gas inside the tank most of the time.

LOL! Gotta love (NOT!) those polys! :-)

Maddmatt 01-29-2006 12:46 PM

Thanks Jeff. I just filled it up and drove about 50 miles, no leaks and no fumes so I'm pretty happy. I'll run it real dry, and then try loosening and re-tightening that plug. Overall I'm pretty happy, plus the tank took over 15 gallons, big step up from the 12 or so my poly tank took.


All times are GMT -6. The time now is 03:52 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.