Rising Sun Member Forums

Rising Sun Member Forums (http://www.risingsun4x4club.org/forum2/index.php)
-   Trip and Event Reports (http://www.risingsun4x4club.org/forum2/forumdisplay.php?f=4)
-   -   BOWAGWR Pics (http://www.risingsun4x4club.org/forum2/showthread.php?t=7606)

CardinalFJ60 07-09-2008 10:13 PM

BOWAGWR Pics
 
1 Attachment(s)
Great run! sure beats workin', EH!? Thanks Isaac for leading us on a great run. One of my favorite quotes was from Corsair..."I want the line where I DON'T do a wheelstand"...see pics below.

more to follow - but here are a few.

Isaac is first look close...wheel stand - that's about half as high as he was. Ken gettin' all flexy where most of us did big ol'wheelstands. and Corsair "not" doing a wheelstand.

CardinalFJ60 07-09-2008 10:15 PM

romer flexing
 
1 Attachment(s)
here's Romer showing off his 80 series flexi-ness.

CardinalFJ60 07-09-2008 10:20 PM

Corsair not doing a wheelstand
 
1 Attachment(s)
three on the ground ain't bad.

wesintl 07-09-2008 11:05 PM

2 Attachment(s)
Couple pics... thanks for taking the lead issac!

AxleIke 07-09-2008 11:23 PM

First of all, can anyone confirm that Matt Ralston made it home okay? I kept my eyes out on the way back, but didn't see any green 40's on the side of the road.

Thanks for the great run guys, It was a great day, and a fun run.

Thank you for asking me to lead as well. I hope it was okay. Hard to balance going fast enough to keep people from getting bored, and slow enough as to not leave people behind.

We didn't lose anyone, so I guess that is something.

Sorry for the wheelstands those who didn't want it. I thought I had 40's figured out, but next time, I will do the LWB guys, and let a more experienced 40 spotter do the shorties.

I tried to get Jeff up that right side to keep his rear out of the deepest part of the hole, but it still lifted sky high.

Ah well, it wasn't really hairy, but I like people to feel comfortable.

Anyway, had a blast! Thanks again.

AxleIke 07-09-2008 11:27 PM

Oh, and the dern tub is okay. But it did leak a bit. Turned out to be a leaky threaded coupler. Little teflon tape and good as new. Landlord is going to fix the celing later, as we caught it soon enough and I fanned it a bit to dry it out.

Red_Chili 07-10-2008 07:28 AM

For a minute there I was trying to figure out the connection between a 4Runner and a 'tub', wasn't sure where the threaded coupler was on a 40... :lmao:

Be sure to check out the post on Slaughterhouse in the Land Use forum!!!

subzali 07-10-2008 07:35 AM

Well it doesn't look like I'm going to get fired, so I guess that's a good thing...

Fun run! Thanks everybody! It was good to get on Slaughterhouse again!

Romer 07-10-2008 07:40 AM

Great run as always. Great group of people.

Jacket 07-10-2008 08:42 AM

I made it home....barely. I figured it was better to take my chances in the daylight hours than risk a tranny failure at 9 or 10 pm.

Once I pulled back onto 285, I shifted it into 4th, and stayed that way until I was about 5 miles from home (took the long way - all interstate). As long as I kept it in gear, it mostly kept going. There were some VERY weird noises coming from the tranny box - lots of whining, chirping, and other metallic noises singing from down below. That and the occasional loss of forward power.:rolleyes:

I'm thinking a new 4 spd might be in my future.....

Thanks to Crash, Dean and Redfox for accompanying me out!


All times are GMT -6. The time now is 05:35 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.