View Single Post
  #1  
Old 06-02-2013, 02:15 PM
MisledYouth's Avatar
MisledYouth MisledYouth is offline
Lifted
 
Join Date: May 2013
Location: Littleton, CO / Erbil, IQ
Posts: 117
Unhappy Any Orion wizards in here?

I got my 40 back from Proffitt's in July of last year, and went immediately to Moab afterword. I'm still working overseas so I have to smash all of my fun into 35 days. Anyway, I was having trouble getting my Orion 4/1 to shift, so I rang them up and we got it sorted out. It worked GREAT until I took it out to Moab in early April on another break. Basically, it would gear down when I shifted, but the front drive would not engage. So I tooled around in 2WD the whole time on Hell's and Gold Bar and so on.

I'm not the most mechanically minded individual, and now I'm gone most of the time, so I'm having my brother run around trying to get this thing looked at before I get home around July/August. He's close with the guys at High Country as he's worked for a couple of their buddy shops in the area and I was just going to have him take it there. I figured I'd check here first though before I take it in.

SUMMARY: ORION 4/1 shifts and gears down, but front drive will not engage. Also, there is not much of a noticeable difference between hi and lo range (both are basically lo).

If anyone has any ideas or shop recommendations, I'm all ears. Thanks guys.

GRATUITOUS 2WD PLAY SHOT!!!!
__________________
Zach Feiler | Littleton, CO
3rd Battalion 5th Marines India Company 2005-2009
"Get Some"

1979 FJ40 - "The Phun Express" - Smurf blue
- 5.3 Vortec - 4L60E - Orion 4:1 -SOA front / 4-link rear - FJ60 axles - ARB's - 4.88's - 37's

1999 UZJ100
- factory locker/ARB front - 285/75r16 Duratracs - Slee 2.5" Heavy Kit - Slee Blueberry/Warn VR10000 - Slee tube sliders - EMS cat-back
Reply With Quote