Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #1  
Old 04-23-2009, 12:39 PM
SteveH SteveH is offline
Hard Core 4+
 
Join Date: Aug 2006
Location: Colo Springs
Posts: 1,320
Default Ghetto FZJ80 PS fix

My '95 FZJ80 had a noisy, low-boost PS pump at about 100K miles, so I bought a reman from Toyota. A few years later and 40K miles, it too was noisy and lacked boost. Lately, it had gotten a lot worse. Rather than toss another $300 pump at it, I added a partial bottle 'Rislone power steering conditioner' to the system. I added some, let it run, siphoned out the reservoir, etc. until I had added about 6 oz from the 12 oz bottle. The stuff looks 140 wt. gear oil on a cold day - about like honey. It has, however, completely quieted the system and the boost is back. It may dissolve all the lines and seals - we'll see about that. is happy now, and that matters some.
Reply With Quote
  #2  
Old 04-23-2009, 06:09 PM
nuclearlemon's Avatar
nuclearlemon nuclearlemon is offline
Hard Core 4+
 
Join Date: Aug 2005
Location: denver
Posts: 5,752
Default

sounds like the lucas stuff.
__________________
ige tlca #1431
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:41 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.