Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #21  
Old 11-03-2010, 02:18 PM
Beater's Avatar
Beater Beater is offline
Hard Core 4+
 
Join Date: Dec 2005
Location: denver
Posts: 2,779
Default

nothing worse than chasing down a suction loss...
__________________
a near-death experience is just god following "catch and release" regulations...


john (johnny) henley
Reply With Quote
  #22  
Old 11-03-2010, 07:11 PM
DanS's Avatar
DanS DanS is offline
Rising Sun Member
 
Join Date: Jul 2010
Location: Idaho Springs
Posts: 509
Default

I just finished the head gaskets on my sister's 3.0.

Vacuum leaks for us too. In my case it was the RH PCV valve hose, it got knocked off at some point, and after the intake was back on it's pretty hidden.

Either way, get a can of starter fluid, and with the engine idling give a short squirt where you think the leak is. If the engine smoothest out or races a little then you've at least found the general area to investigate.

Dan
Reply With Quote
  #23  
Old 11-04-2010, 11:23 AM
AxleIke's Avatar
AxleIke AxleIke is offline
Rising Sun Member
 
Join Date: Apr 2006
Location: Arvada, CO
Posts: 3,387
Default

Good idea Dan. I'll be working out several issues at once.

I'm about 90% sure the throttle position sensor is fried. The actual sensing is fine, but the idle circuit resistance does not match up anywhere with the proper readings in the FSM.

Ordered a new one, should be here tomorrow. I'll tackle it again this weekend.
__________________
Isaac

Baby Beast 2- 1999 4Runner SR5

Baby Beast -1987 4Runner SR5-Gone, but not forgotten

Generation Dead
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 02:40 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.