Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Thread Tools
Old 04-04-2011, 09:23 AM
rover67's Avatar
rover67 rover67 is offline
Rising Sun Member
Join Date: Nov 2007
Location: Boulder, Co
Posts: 5,737

I didn't because it looked like it was just gounding the case, and in my installation the screws that hold it down go to the body...

But, if on yours it just screws to the wooden box it might be a good idea now that you mention it. I bet some regular copper wire that you have left over from the basement might work fine since the main ground is what carries the power. It's probably a safety thing and maybe it doesn't affect the normal operation of the thing that much? I bet Dave knows
Marco Capote
85 FJ60
82 FJ40
Reply With Quote
Old 04-04-2011, 09:26 AM
nakman's Avatar
nakman nakman is offline
Rising Sun Commander
Join Date: Aug 2005
Location: north side
Posts: 10,414

Alright I may as well, and yes I've got some 12ga copper that would be great for this, I'll loop it under to the back and attach to the 4ga that runs under the truck to the frame.
82 fj40, 99 uzj100, 06 gx470

05 525EXC, 01 XT225, 07 TTR90, 07 CRF50


Reply With Quote
Old 04-04-2011, 11:35 AM
Jacket's Avatar
Jacket Jacket is offline
Rising Sun Member
Join Date: Feb 2007
Location: Lafayette
Posts: 4,343

That's funny - I forgot to ground my case too. Mine is mounted to wood, so I probably should at some point....
- Matt
1976 FJ40 - green and mostly stock
1996 FZJ80 - not so stock
Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -6. The time now is 08:26 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.