Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Chit Chat

Reply
 
Thread Tools
  #41  
Old 09-03-2013, 02:50 PM
Red_Chili's Avatar
Red_Chili Red_Chili is offline
Hard Core 4+
 
Join Date: Aug 2005
Location: Littleton CO
Posts: 8,409
Default

So I replaced the rad cap with the appropriate 7psi working unit (specified in O'Reilly's book for a 1955 Chrysler or DeSoto whatever... ). Works great. Now the cooling system develops pressure.


Until the pinhole in the radiator seam leaks it out, along with the water pump seal...


Good thing this stuff is available fairly cheap... found a shop who actually remembers how to solder together a radiator. Better than throwing a Chinese 'sorta' reproduction radiator in it.

Changed the oil... it NEEDED it. Found out the oil filter access cover in the oil pan was welded shut, as many were (inasmuch as they were very difficult to seal). Sigh. Not a big deal to pull the oil pan, but not having planned on it, I had no gasket. Oh well, it needed some 'cleanout' oil run through it for a while anyway.

I keep thinking about that pretty little fully restored Fergie that came on the market AFTER I bought this one. For more than twice as much, but... ah well, I got a lot more work to do before I burn through THAT much difference.
__________________
-Bill Morgan
Heb Dduw, heb ddim; Duw a digon
Abnormally aspirated
KDěRCH
Bio Page
I'm that gun-totin', farm-raised, evangelical, pro-environment, OHV ridin'/drivin', Southern civil rights pro-labor Liberal yo' momma told you couldn't possibly exist.
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 08:47 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.