Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #1  
Old 02-22-2009, 08:10 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default 3FE Troubleshooting

So I have this 3FE in a Pig and have been tracking down little issues.

The most concerning one is an intermittent idle problem. Sometimes when warm, I will lose the ability to idle.

I am swapping out radiators this weekend and thought I would pull the throttle body and ISC to check them for function and spec.

Also checked air flow meter - it checks good against specs in the FSM

ISC checks good - both resistance and stepping.

Throttle body checks good, EXCEPT when clearance btwn lever and stop screw is supposed to be set to 1.09 mm or 0.0429".

I used two feeler gauges together to achieve thickness: .559 mm and .533 mm to achieve 1.092 mm. So it is a little fat, but that was the best I could come up with in the moment.

FSM says resistance at IDL and E2 is supposed to be infinite, I got zero

I may have been off a little, trying to arrange the throttle body and feeler gauges, and take a measurement at terminals...

Can anyone advise me if it is common for the throttle body to pass every other check, but fail here?
Attached Images
 
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
  #2  
Old 02-23-2009, 08:47 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default

No Love?

Dang, I can't get boo out of the 60/62 forum on MUD w/ these questions.

Is the yahoo 3FE list my only place to field these mundane requests?
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
  #3  
Old 02-23-2009, 09:02 PM
Crash's Avatar
Crash Crash is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Denver
Posts: 1,860
Default

[quote=PabloCruise;98242]No Love?

Dang, I can't get boo out of the 60/62 forum on MUD w/ these questions.

Is the yahoo 3FE list my only place to field these mundane requests?[/QUOT

Yes, TJ, the 3FE list is the only place in the world where you can get reliably mundane, but generally correct, info on the mighty 3FE fury of an engine.
It sounds as if your TPS is DOA and the only way to make it right is to replace it. Not that big of a deal really. They tend to get gunked up internally and not allow full travel of the internal mechanical parts which, in turn, sends erroneous electrical info to the not-very-smart 3FE computer (ECU). If you can't get it to match the FSM specs while you have it on the bench, replace the TPS. Be aware, however, that there are two throttle stops in the same tight area when the TPS is mounted to the throttle body and if you are trying to set the clearance specs on the dash pot stops, your TPS specs will be close but not correct and cause you some dismay.
Reply With Quote
  #4  
Old 02-24-2009, 04:45 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default

Thanks Crash.

I am puzzled that the other positions check fine, just the one at 1.09 mm is opposite of spec.

In your experience, if I am off a little on that 1.09 mm gap, is that enough to give me a zero resistance vs. infinity?

Anyone have a TPS that passes they want to sell?
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
  #5  
Old 02-24-2009, 05:11 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default

Crash,

Is the not-very-smart 3FE computer happy if the CEL has been removed?
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
  #6  
Old 02-24-2009, 09:45 PM
Crash's Avatar
Crash Crash is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Denver
Posts: 1,860
Default

I detest electrical stuff. If the TPS doesn't spec out as it should on the bench, IMO, the best thing to do is buy a new one. Saving a few $$ on a used one is too risky, again, IMO. As for the ECU being affected by no CEL, I am not in the know. There are a couple of guys on the 3FE list that could help you though. It's very quiet there these days but Wayne Tangen is the acknowledged electrical guru and he usually checks in on the list every few days or so. Couldn't hurt to ask there.
When checking the TPS, if you see the correct resistance at the skinnier clearances and then resistance goes to zero at a wider opening rather than infinity, then I would say the TPS should be replaced.
Reply With Quote
  #7  
Old 02-25-2009, 12:24 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default

Got it, thanks.

I'll field the CEL question to the list and hope that Wayne weighs in on the matter...
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
  #8  
Old 02-26-2009, 06:01 PM
PabloCruise's Avatar
PabloCruise PabloCruise is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Northern CO
Posts: 1,735
Default

Quote:
Originally Posted by Crash View Post
When checking the TPS, if you see the correct resistance at the skinnier clearances and then resistance goes to zero at a wider opening rather than infinity, then I would say the TPS should be replaced.
What is odd is that I re-checked the TPS today and the two checks at WOT now fail. I swear on Sunday they were w/in spec, but now they go to 0...

I'm replacing.
__________________
TJS

1978 FJ-40
1974 FJ-55 w/ 3FE

TLCA #10713

CO/WY Horsetooth 4 Wheelers Cruiser Club - Click Here!
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:33 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.