Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #101  
Old 04-08-2013, 11:34 AM
J Kimmel J Kimmel is online now
Hard Core 4+
 
Join Date: Oct 2005
Location: Lakewood
Posts: 920
Default

Ya me too, that's why I had him do it. Should be easily accessible for service but it is doubtful ill ever need to
Reply With Quote
  #102  
Old 04-10-2013, 10:28 PM
J Kimmel J Kimmel is online now
Hard Core 4+
 
Join Date: Oct 2005
Location: Lakewood
Posts: 920
Default

finished my dash, kept it real simple...I also made an adapter for my air filter tonight. Cut a plate and welded on some 3" exhaust pipe and put this filter on there.

should be all set to start up this weekend Its only been almost a year

I'm getting down to odds and ends and cosmetic stuff
Attached Images
  
Reply With Quote
  #103  
Old 04-10-2013, 10:33 PM
baja1d's Avatar
baja1d baja1d is offline
Hard Core 4+
 
Join Date: May 2010
Location: Littleton, CO
Posts: 1,451
Default

Man that looks great
__________________
Travis
TLCA#: 22078
1994 FJ80
1964 FJ40
1988 4Runner
Reply With Quote
  #104  
Old 04-11-2013, 01:27 AM
Uncle Ben's Avatar
Uncle Ben Uncle Ben is offline
Rising Sun Member
 
Join Date: Aug 2005
Location: Louisville, Colorado
Posts: 13,151
Send a message via AIM to Uncle Ben
Default

It looks awesome although there is still some mintruck there. Need to go back in and cut deeper!
__________________
KUBN
Kevin
TLCA #3007
Northside!

Colorado Trail Patrol
Stay on the Trail!
I'm the God-fearing, gun-toting, American flag-waving, conservative you were warned about!
Quote:
Originally Posted by AxleIke View Post
I need an FJ40....
Quote:
Originally Posted by Red_Chili View Post
Cruisers are superior
Reply With Quote
  #105  
Old 04-11-2013, 07:53 AM
AxleIke's Avatar
AxleIke AxleIke is offline
Rising Sun Member
 
Join Date: Apr 2006
Location: Arvada, CO
Posts: 3,384
Default

Quote:
Originally Posted by Uncle Ben View Post
It looks awesome although there is still some mintruck there. Need to go back in and cut deeper!
Says the guy who's been slowly adding mini truck to his land cruiser!
__________________
Isaac

Baby Beast 2- 1999 4Runner SR5

Baby Beast -1987 4Runner SR5-Gone, but not forgotten

Generation Dead
Reply With Quote
  #106  
Old 04-11-2013, 07:54 AM
AxleIke's Avatar
AxleIke AxleIke is offline
Rising Sun Member
 
Join Date: Apr 2006
Location: Arvada, CO
Posts: 3,384
Default

Great work Jeremy!
__________________
Isaac

Baby Beast 2- 1999 4Runner SR5

Baby Beast -1987 4Runner SR5-Gone, but not forgotten

Generation Dead
Reply With Quote
  #107  
Old 04-11-2013, 08:46 AM
J Kimmel J Kimmel is online now
Hard Core 4+
 
Join Date: Oct 2005
Location: Lakewood
Posts: 920
Default

Thanks, its moving slowly but last night seemed like a good amount accomplished. Wiring will be all wrapped this weekend, and I *think* aside from shock tuning and leak mitigation the bulk of whats left is cosmetic. Hopefully it warms up a bit here very soon so I can start painting tubes and stuff...gotta bedline the interior then I can permanently mount the seats and belts.


I'm really starting to look forward to Moab and then Rock Junction at the end of May
Reply With Quote
  #108  
Old 04-14-2013, 01:01 AM
J Kimmel J Kimmel is online now
Hard Core 4+
 
Join Date: Oct 2005
Location: Lakewood
Posts: 920
Default

It runs

First try almost all new wiring
Reply With Quote
  #109  
Old 04-14-2013, 03:35 AM
RockRunner's Avatar
RockRunner RockRunner is offline
Hard Core 4+
 
Join Date: Nov 2006
Location: Roxborough
Posts: 4,400
Default

Awesome Brian does know his stuf!
__________________
Thanks T aka Tom KR0MPS

Quote:
Originally Posted by RockRunner;
keys = Man that is a whole story


TLCA #6136
Going under the knife again !

85 4runner Marlin Ultimate 5" lift 40" MTR's Soft top and doors Towed to Moab by the Big Blue Whale, 07.5 Dodge Mega Cab Laramie 4" lift covered and chiped No more slow lane for me
Reply With Quote
  #110  
Old 04-15-2013, 09:37 PM
J Kimmel J Kimmel is online now
Hard Core 4+
 
Join Date: Oct 2005
Location: Lakewood
Posts: 920
Default

little more done tonight

I sanded the fenders good and shot some primer on them, I also trimmed them out for my LED's in the front and got those mounted. Yesterday I put some bondo on the rears, I think I need another light coat over the gas door I welded over. I apparently mixed up my ram assist lines, so I fixed that and bled out the system.

Here's one for someone who knows more than me...I filled the radiator with coolant and fired it up. I left the cap off, and let it run to get up to temp. It finally got I guess to temp and it started spewing coolant, like a geyser I shut it off and it stopped. Then I put the cap on, and repeated. I opened the cap once I shut it off really slowly and then re-filled and it seems ok?

What would cause that? I've seen plenty of times where the level will just drop when the t-stat opens and you add more, never saw old faithful

thanks
Attached Images
    
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 10:22 PM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.