Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #1  
Old 01-10-2007, 07:40 PM
Jenny Cruiser's Avatar
Jenny Cruiser Jenny Cruiser is offline
Hard Core 4+
 
Join Date: Nov 2006
Location: North of Hell
Posts: 817
Default 97 LX450 Engine Pic

How's this look for a 97 LX w/120K on it? I've already got a new PCV and hoses 1&2.
Attached Images
 
Reply With Quote
  #2  
Old 01-11-2007, 03:09 PM
Hulk's Avatar
Hulk Hulk is offline
Cruise Moab Committee
 
Join Date: Aug 2005
Location: South Side!
Posts: 11,463
Send a message via AIM to Hulk
Default

There's a weird logo on the valve cover. Something must be wrong.
__________________
Matt Farr, Centennial, Colorado | Webmaster: TLCA.org
1996 FZJ80 TLCA #4189 WRDY
www.rustybrain.com/cruisers my Rising Sun bio Facebook Twitter Need satellite Internet? Check out: Exede Internet

If you think you can or think you can't, you're right.
Reply With Quote
  #3  
Old 01-11-2007, 07:14 PM
nakman's Avatar
nakman nakman is offline
Rising Sun Commander
 
Join Date: Aug 2005
Location: north side
Posts: 10,006
Default

No grill, no hot dogger, and that DS firewall grommet doesn't even have one stinkin' wire running through it. phooey.
__________________
99 uzj100, 05 525EXC

www.gamiviti.com

Reply With Quote
  #4  
Old 01-11-2007, 07:21 PM
bigbluefj's Avatar
bigbluefj bigbluefj is offline
Honorary Canuck Member
 
Join Date: Oct 2005
Location: canmore alberta canada
Posts: 1,121
Send a message via Yahoo to bigbluefj
Default

so would something like that with a supercharger work in a 40??? hmmmm

kevin
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 03:55 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.