Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Thread Tools
Old 08-13-2008, 09:46 PM
nakman's Avatar
nakman nakman is offline
Rising Sun Commander
Join Date: Aug 2005
Location: north side
Posts: 10,294
Default Send your tech questions to Toyota Trails

Folks, now is your opportunity to immortalize yourself in TLCA history, with your very own tech question answered by the new Tech Editor... Go ahead, just try & stump him.

send your emails to techeditor@tlca.org.

ps- no, it's not me.
82 fj40, 99 uzj100, 06 gx470

05 525EXC, 01 XT225, 07 TTR90, 07 CRF50


Reply With Quote
Old 08-14-2008, 07:02 AM
Red_Chili's Avatar
Red_Chili Red_Chili is offline
Hard Core 4+
Join Date: Aug 2005
Location: Littleton CO
Posts: 8,400

Already sent one to Roger Brown related to my inexplicably rough idle on my rebuild ('93 pickup - and it is completely fixed now, will idle down to 500 RPM if I wanted)... is he no longer the minitruck tech guy?
-Bill Morgan
Heb Dduw, heb ddim; Duw a digon
Abnormally aspirated
Bio Page
I'm that gun-totin', farm-raised, evangelical, pro-environment, OHV ridin'/drivin', Southern civil rights pro-labor Liberal yo' momma told you couldn't possibly exist.
Reply With Quote

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

All times are GMT -6. The time now is 11:20 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.