Rising Sun Member Forums  

Go Back   Rising Sun Member Forums > Toyota 4x4 > General Tech Forum

Reply
 
Thread Tools
  #1  
Old 09-06-2008, 07:39 PM
Air Randy's Avatar
Air Randy Air Randy is offline
Cruise Moab Committee
 
Join Date: Aug 2008
Location: Franktown, CO
Posts: 2,804
Default FJ40 Brake Issues

I bought SOA front & rear axles complete with lockers, disc brakes on the front and new shoes in the rear drums.

I also purchased the Toyota single reservoir high flow master cylinder that was recommended when adding disc brakes.

I installed the new master cylinder and rear axle last weekend but am having a weird problem with the rear brakes. I bled all of the lines really good and the pedal is rock hard. However, after driving around for some time and using the brakes the rear brakes seem to eventually lock up and get so tight I can't even move the vehicle.

I pulled the drums off, couldn't find any problems and adjusted the shoes down so they weren't dragging too much. That seemed to take care of the problem until I installed the front axle today with the discs on it. I bled the front lines and took off on a test drive. All seemed well until about 30 minutes into the drive and the back brakes locked up again, so tight they were smoking by the time I could get pulled over.

Fortunately I had a small wrench with me and was able to pull the plug out of the bottom of the master cylinder. About a tsp of fluid came out but that was enough to release the rear brakes. I was able to get home without problems.

I know I've read somewhere that the drum brake system have a 6 lb residual valve but I have no idea where it is. Unless its defective and hanging up it shouldn't be an issue, though I understand I'm supposed to go to a 2 lb residual valve now that I have the dics on the front.

Anyone have any ideas as to what my issue is?
Reply With Quote
  #2  
Old 09-06-2008, 07:59 PM
frontrange frontrange is offline
Locked
 
Join Date: May 2008
Location: Colorado Springs
Posts: 292
Default

Hey Randy - I don't think that master has a residual valve setup, but I'll check mine to be sure. They are in-line with the brake lines on the stock master IIRC. Are your wheel cylinders all working? Could be an out of round drum or a bad adjuster too.
Reply With Quote
  #3  
Old 09-06-2008, 09:32 PM
Air Randy's Avatar
Air Randy Air Randy is offline
Cruise Moab Committee
 
Join Date: Aug 2008
Location: Franktown, CO
Posts: 2,804
Default

I was thinking about pulling the wheel cylinders, shoes and drums off of my original axle and installing those since I never had any problems with them locking up. Let me know where the residual valve is though so I can check to see if there is a problem with that too.
Reply With Quote
  #4  
Old 09-07-2008, 09:10 AM
frontrange frontrange is offline
Locked
 
Join Date: May 2008
Location: Colorado Springs
Posts: 292
Default

If you pull the lines off the late Toyota master and look inside, you'll see some copper fittings inside. My guess is that would have to be the check valves, though its hard to say without the manual for whatever vehicle was equiped with these masters, maybe an FJ80? You should check with JT Outfitters again and make sure that that cylinder is appropriate for a rear drum setup, I thought it was 4 way disc only.

Anyway, I still think your problem is most likely at the rear brakes. I'd check all your old cylinders for free travel and then swap them in and make sure your adjuster and the rest of the hardware is free of rust and debris and then give it another good bleed. Swapping the drums is a good idea too. Lots of drums and discs come from China now and are out of round. I always get north American cast iron, or chuck it on the lathe and check for out of round.

One other think I forgot, did you bench bleed that master when you installed it? I hear its very hard to get all the air out of the system if you skip that step. If you haven't done it, just use the kit I loaned you to make some short lines that turn back into the master cylinder resevoir and pump the hell out of it till you are free of air bubles and then reattach the front/rear lines and bleed again.

Last edited by frontrange; 09-07-2008 at 09:44 AM.
Reply With Quote
  #5  
Old 09-07-2008, 06:14 PM
subzali's Avatar
subzali subzali is online now
Rising Sun member
 
Join Date: Aug 2005
Location: Denver CO
Posts: 7,507
Default

You might not have enough freeplay between your master cylinder and the brake booster push rod. Happened to me. Or not enough freeplay between the pedal and the brake booster.
__________________
Matt Miller
"Stay the Trail," "Tread Lightly," and "Leave No Trace" ethics
TLCA# 13684
Rising Sun Bio
1977 FJ40 2F "Brahma" + Lockright, tach, Warn 8274, FJ60 Power Steering, soon to lose the Sanden OBA to go back to factory emissions
1996 FZJ80 1FZ-FE factory lockers + Safari Turbo , CDL switch, cup holder, AATLAS1X leather, heated seats and JDM switches
2000 Tundra Limited TRD 2UZ-FE SOLD
Reply With Quote
  #6  
Old 09-07-2008, 08:33 PM
Air Randy's Avatar
Air Randy Air Randy is offline
Cruise Moab Committee
 
Join Date: Aug 2008
Location: Franktown, CO
Posts: 2,804
Default

I threw a set of disk brakes on the rear today, that seems to have fixed it!

Thanks everyone
Reply With Quote
Reply

Thread Tools

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


All times are GMT -6. The time now is 07:29 AM.


Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.